Jeuxlinux - Le site des jeux pour linux - Forum

Forum francophone des jeux pour GNU/Linux

Vous n'êtes pas identifié.

#1 05-01-2008 10:48:48

Grigrifounet
Membre

Problème de framebuffer... Ou de SDL ... J'en sais rien en fait :D

Bonjour à tous. J'ai découvert ce site recemment, et je dois dire que j'en suis déjà fan, depuis le temps que je cherchais quelque chose comme ça ^^. Bon, mais déjà un problème...

J'ai essayé d'installer Scorched 3D. Etant sous Debian Sid, no prob, il est dans les paquets. L'installation s'est déroulée normalement, mais quand est venu le temps de le lancer...

Code:

grigri@Zeplin:/usr/games$ ./scorched3d

     =======================|  DirectFB 1.0.1  |=======================
          (c) 2001-2007  The DirectFB Organization (directfb.org)
          (c) 2000-2004  Convergence (integrated media) GmbH
        ------------------------------------------------------------

(*) DirectFB/Core: Single Application Core. (2007-12-11 00:57)
(!) Direct/Util: opening '/dev/fb0' and '/dev/fb/0' failed
    --> No such file or directory
(!) DirectFB/FBDev: Error opening framebuffer device!
(!) DirectFB/FBDev: Use 'fbdev' option or set FRAMEBUFFER environment variable.
(!) DirectFB/Core: Could not initialize 'system' core!
    --> Initialization error!
Scorched3D - Version 41.1 (dj) : Warning: This game uses the SDL library to provide graphics.
The graphics section of this library failed to initialize.
You will only be able to run a server for this game.
Error: Unable to initialize gtk, is DISPLAY set properly?

Et là bah... je n'arrive pas bien à comprendre quel est le problème.. C'est quoi 'system' core ? J'ai dans l'idée qu'il me manque juste un ou deux paquets, du coup je me suis dis que si vous quelqu'un connaissais le problème par ici smile . (en attendant, je cherche de mon coté).

J'ai installé Btank, et rebelote, même problème.

Merci d'avance !

Hors ligne

 

#2 05-01-2008 12:35:37

julroy67
Modérateur

Re: Problème de framebuffer... Ou de SDL ... J'en sais rien en fait :D

On dirait que tu lance ces jeux en console (sans X.org), si c'est le cas faut le lancer dans X.org, sinon je comprends pas pourquoi il veut initialiser l'interface FB.

Hors ligne

 

#3 05-01-2008 13:29:44

Grigrifounet
Membre

Re: Problème de framebuffer... Ou de SDL ... J'en sais rien en fait :D

Ouais, c'est ce qui se dis ailleur. Pour autant je suis bien en mode graphique (avec les magnifiques effets de compiz, gaaah)...

La SDL est têt pas installé tiens, ça pourrait venir de là ?

Edit : tout bien réflechi, y a aucune raison qu'elle soit installé si ? J'vais déjà essayer de faire ça >< .

Dernière modification par Grigrifounet (05-01-2008 13:33:07)

Hors ligne

 

#4 05-01-2008 13:52:23

julroy67
Modérateur

Re: Problème de framebuffer... Ou de SDL ... J'en sais rien en fait :D

Ben si tu l'as installé par apt elle doit être installée, c'est une dépendance. Je penche plutôt sur un problème du a Compiz, essaie de le désactiver une fois pour voir.

Hors ligne

 

#5 05-01-2008 15:44:25

lululaglue
Administrateur

Re: Problème de framebuffer... Ou de SDL ... J'en sais rien en fait :D

Salut,

Qu'elle carte graphique as-tu ?
Qu'as-tu installé comme pilote ?
L'accéleration materielle fonctionne t'elle ?


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#6 05-01-2008 18:49:58

Grigrifounet
Membre

Re: Problème de framebuffer... Ou de SDL ... J'en sais rien en fait :D

Mmm J'ai trouvé d'ou venait le problème je crois. Je n'avais plus de place sur la partition racine, j'ai fait du menage et le problème à disparu (j'en ai d'autre, mais je devrais pouvoir m'en sortir smile ).

Merci quand même a vous deux !

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr