Jeuxlinux - Le site des jeux pour linux - Forum

Forum francophone des jeux pour GNU/Linux

Vous n'êtes pas identifié.

#1 15-09-2006 11:43:10

Otimer
Invité

Je n'arrive pas a lancé Savage...

Bonjour à tous!
J'ai réussi grâce au tutoriel présent sur le site à installer le jeu Savage. Lorsque je le lance, celui-ci me dirige vers l'écran de mise à jour, me dit que tout est à jour puis l'écran devient noir et j'obtiens un message d'erreur :

root@remi-desktop:~# cd /usr/local/games/Savage
root@remi-desktop:/usr/local/games/Savage# sudo ./savage
System_Init()
Mem_Alloc: Couldn't allocate -1292288240 bytes

Voilà, si quelqu'un pouvait m'éclairer ce serait super. Merci!

 

#2 15-09-2006 20:18:32

lululaglue
Administrateur

Re: Je n'arrive pas a lancé Savage...

Salut, tu peux déjà essayer de le lancer en utilisateur "normal" pas en root. Pour cela :

cd /usr/local/games/Savage
sudo chmod +x savage
./savage

Quand tu est en utilisateur normal tu dois voir un $ dans ta console, et un # quand tu est root.

Sinon donne nous ta config matériel ? et vérifie si il te reste de l'espace disque et mémoire de libre.
df -h =>espace disque
free -m => mémoire


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#3 16-09-2006 01:14:38

Otimer
Invité

Re: Je n'arrive pas a lancé Savage...

Merci de m'avoir répondu!
Lorsque je lance Savage sans être en root, j'obtiens le message suivant pendant la mise à jour :

"There was an error checking for updates : Could not create local patch index."

Si je le lance en root, il me dit que le jeu est bien à jour puis j'obtiens le message d'erreur donné dans mon premier message.

Configuration matérielle :
Athlon XP 3000+
Nvidia Geforce 6600GT (le driver Nvidia est installé)
Je tourne sous Ubuntu 6.06 Dapper Drake

remi@remi-desktop:~$ df -h
Sys. de fich.            Tail. Occ. Disp. %Occ. Monté sur
/dev/hda2              13G  5,9G  5,6G  52% /
varrun                379M   80K  379M   1% /var/run
varlock               379M  4,0K  379M   1% /var/lock
udev                  379M  132K  379M   1% /dev
devshm                379M     0  379M   0% /dev/shm
lrm                   379M   19M  361M   5% /lib/modules/2.6.15-26-386/volatile

remi@remi-desktop:~$ free -m
             total       used       free     shared    buffers     cached
Mem:           757        432        325          0         46        250
-/+ buffers/cache:        136        621
Swap:          564          0        564

Voila, si cela peut vous aider à m'aider ^^. Merci!

 

#4 16-09-2006 03:42:01

lululaglue
Administrateur

Re: Je n'arrive pas a lancé Savage...

Désolé je n'ais aucune idée d'ou cela peux venir sad

Mais si j'étais toi, je réinstallerais savage en tant qu'utilisateur normal (sans sudo le lancement de l'install) avec comme répertoire d'installation /home/mon_user/savage + install patch.

Bon courage wink


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#5 16-09-2006 14:39:12

Otimer
Invité

Re: Je n'arrive pas a lancé Savage...

Bonjour!
J'ai suivi votre conseil et j'ai réinstaller le jeu dans un répertoire différent. J'ai ensuite appliqué le patch, puis extrait l'archive SEP-3T. Maintenant, lorsque je lance le jeu, un autre message s'affiche :

remi@remi-desktop:~$ cd /home/remi/Jeux/Savage
remi@remi-desktop:~/Jeux/Savage$ ./savage
System_Init()
Couldn't open debug.log for writing
Signal SIGABRT received.

Stack dump:
{
        ./silverback.bin [0x8094004]
        ./silverback.bin [0x80947ae]
        ./silverback.bin [0x808aef7]
        ./silverback.bin [0x8094ca5]
        /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xd2) [0xb77e4ea2]
        ./silverback.bin(__gxx_personality_v0+0xd5) [0x804d671]
}

remi@remi-desktop:~/Jeux/Savage$

Voilà, je pense que je vais encore avoir besoin de vos lumières. Merci!

 

#6 17-09-2006 15:36:07

lululaglue
Administrateur

Re: Je n'arrive pas a lancé Savage...

Et si tu essaye de lancer directement silverback.bin ?


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#7 07-03-2007 20:04:36

caribou
Invité

Re: Je n'arrive pas a lancé Savage...

moi c pareil c tro bizarre jarive po a l'instalé é kan je v sur le net pour pouvoir télécharger la version complète il me mé tt en linux dc je peu po le mettre en linux vu ke je sui en windows ki peu médé pour télécharger la version complète !?

 

#8 07-03-2007 20:18:22

lululaglue
Administrateur

Re: Je n'arrive pas a lancé Savage...

Il existe un nouveau paquet pour Savage, qui s'appel SFE. Sur cette page tu trouveras un paquet pour Windows (http://www.notforidiots.com/SFE/).
Prends le fichier standalone et supprime ton ancienne version de Savage avant de l'installer.

+


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr