Jeuxlinux - Le site des jeux pour linux - Forum

Forum francophone des jeux pour GNU/Linux

Vous n'êtes pas identifié.

#1 06-12-2006 18:51:33

Drago
Membre

The mana world

Bonjour à tous, je souhaiterais installer ce jeu (MMORPG gratuit), l'ennui c'est que j'ai Dapper drake et que sur la page de téléchargement, je ne vois que edgy et Debian. Serait-il donc possible de télécharger ce jeu sous Dapper Drake?


Debian/Ubuntu repositories

For convenience to Debian and Ubuntu users, several package repositories have been set up by Bertram. The repositories also contain Guichan, because its latest version isn't generally available yet. Choose the right repository for your system, and add the given line to your sources.list file:
Debian Unstable

deb http://bertram.ifrance.com/ debian unstable

Ubuntu Edgy (i386 and AMD-64)

deb http://bertram.ifrance.com/ ubuntu edgy

Then to install TMW do:

apt-get update
apt-get install tmw

Hors ligne

 

#2 06-12-2006 19:05:55

Drago
Membre

Re: The mana world

Regardez:

Impossible de récupérer http://bertram.ifrance.com/dists/ubuntu … ackages.gz  404 Not Found

>_<

Hors ligne

 

#3 06-12-2006 22:16:58

seb.bernery
Modérateur

Re: The mana world

tu veux pas update vers edgy ? :p
bon je dirais .... essaie de remplacer edgy par dapper (bah quoi ca peut marcher non ? :p )


jabber : sebastienb@jabber.fr
je suis : http://presence.jabberfr.org/c932efdd4f48f2e04772c83a99af1299/image.png ( http://presence.jabberfr.org/c932efdd4f48f2e04772c83a99af1299/image-text-fr.png )
http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#4 06-12-2006 23:30:38

JerhuM
Administrateur

Re: The mana world

effectivement il n'existe pas de dépots pour dapper donc la seule manière est de le compiler
ce qui n'est pas chose simple pour un débutant, surtout que le jeu demande pas mal de dépendance !
mais honnetement installe toi une edgy fraiche , a moins que tu te sent bien avec dapper malgré tout lol !

Hors ligne

 

#5 07-12-2006 00:33:48

lululaglue
Administrateur

Re: The mana world

Personnellement j'était sous edgy et je suis revenu sur dapper ! pour une question de stabilité.


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#6 07-12-2006 01:23:41

Drago
Membre

Re: The mana world

A vrai dire je préfère rester sous Dapper...x_x
Compiler, ce n'est pas chose simple, mais est-ce tout de même faisable pour le noble débutant que je suis? ^^
Eh bien oui je suis très opiniâtre...
Sinon pour les dépendances je suis habitué je crois ^^.

PS: Si avec tous mes topics vous ne vous faites pas une énorme FAQ sur tous les bugs, c'est que quelquechose ne va pas XD.

Dernière modification par Drago (07-12-2006 01:25:01)

Hors ligne

 

#7 07-12-2006 11:37:31

JerhuM
Administrateur

Re: The mana world

Encore faut il les résoudrent tes bugs pour pouvoir les mettre dans la faq !
tu fait fonctionner beaucoup de jeux ?
sinon pour mana world faut trouver quelqu'un qui fasse un tuto,
allez je suis sympa

soit tu essayes d'installer le deb unofficial  : http://www.freewebs.com/tinlayaa/tmw%5F … 5Fi386.deb

ou sinon tu le compiles
les dépendances :
SDL , SDL_mixer, SDL_image, SDL_net, Guichan 0.5.0, libxml2, physfs 1.0.x, zlib 1.2.x, libcurl
ce qui nous donne :

Code:

sudo apt-get build-essential libphysfs-dev libcurl3-openssl-dev libxml2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev

tu auras besoin de guichan : http://www.freewebs.com/tinlayaa/guicha … 5Fi386.deb
ensuite tu récupères les sources tu les décompresses
tu va dans le répertoire et tu fait

Code:

./configure
make

et s'il n'ya pas d'erreur

Code:

sudo make install

voila

Hors ligne

 

#8 07-12-2006 12:48:34

Drago
Membre

Re: The mana world

J'ai essayé de faire le build-essential mais c'était marqué qu'il n'était pas valable, donc j'ai tenté d'installer le deb unofficial.
dpkg -i etc... (je suis bien content de la connaître cette commande ^^)
Je l'ai installé. Ensuite:

drago@drago-desktop:~/Desktop$ tmw
tmw: error while loading shared libraries: libguichan_sdl.so.0: cannot open shared object file: No such file or directory
(je l'ai cherché dans aptitude, ça marchait)

drago@drago-desktop:~/Desktop$ tmw
tmw: error while loading shared libraries: libphysfs-1.0.so.0: cannot open shared object file: No such file or directory
(pareil)

drago@drago-desktop:~/Desktop$ tmw
The Mana World v0.0.21
tmw: symbol lookup error: tmw: undefined symbol: _ZN3gcn14BasicContainer16_setFocusHandlerEPNS_12FocusHandlerE

>_<"
Où est le problème cette fois? XD
(Au fait grand merci pour ton tuto ^^)

EDIT: Je précise quand même:

drago@drago-desktop:~$ sudo apt-get build-essential libphysfs-dev libcurl3-openssl-dev libxml2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev
E: L'opération build-essential n'est pas valable

Dernière modification par Drago (07-12-2006 13:01:19)

Hors ligne

 

#9 07-12-2006 14:09:20

seb.bernery
Modérateur

Re: The mana world

il a oublié le install donc :
sudo apt-get install build-essential libphysfs-dev libcurl3-openssl-dev libxml2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev


jabber : sebastienb@jabber.fr
je suis : http://presence.jabberfr.org/c932efdd4f48f2e04772c83a99af1299/image.png ( http://presence.jabberfr.org/c932efdd4f48f2e04772c83a99af1299/image-text-fr.png )
http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#10 07-12-2006 15:12:40

Drago
Membre

Re: The mana world

drago@drago-desktop:~$ sudo apt-get install build-essential libphysfs-dev libcurl3-openssl-dev libxml2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
build-essential est déjà la plus récente version disponible.
libsdl-image1.2-dev est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  libcurl3-openssl-dev: Dépend: libssl-dev mais ne sera pas installé
                        Dépend: libkrb5-dev mais ne sera pas installé ou
                                 hurd mais il n'est pas installable
E: Paquets défectueux


Hum...XD


drago@drago-desktop:~$ sudo apt-get install libssl-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  libssl-dev: Dépend: libssl0.9.8 (= 0.9.8a-7build1) mais 0.9.8a-7ubuntu0.3 devra être installé
E: Paquets défectueux
drago@drago-desktop:~$ sudo apt-get install libssl0.9.8
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
libssl0.9.8 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

(je comprends plus rien -_-)
Le jeu était installé mais la fenêtre lançait puis quittait, je l'ai désinstallé du coup...

Dernière modification par Drago (07-12-2006 15:15:19)

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr