Jeuxlinux - Le site des jeux pour linux - Forum

Forum francophone des jeux pour GNU/Linux

Vous n'êtes pas identifié.

#1 24-06-2008 18:17:25

Fred6681
Invité

Pas de son sur America's Army

Bonjours,
Je suis sous Mandriva 2008.1 KDE, j'ai installé America's Army qui marche très bien mais je n'ai pas son, quelqu'un pourrais m'aider svp ?

 

#2 24-06-2008 18:41:09

Fred6681
Invité

Re: Pas de son sur America's Army

j'ai suivi ça mais rien ni fait

Code:

le jeu fonctionne, mais...

Q : je n’ai pas de son ?

R : Les problèmes de son, sont un problème récurrent sous Linux. La plupart des jeux natifs Linux utilisent OSS pour la gestion du son, et OSS ne gère pas, de façon logiciel, le mixage des sons. En gros, un programme utilisant OSS s’approprie la carte son et tout autre programme qui essayera de produire un son échouera.

Certaines cartes son permettent le mixage matériel (mais elles sont rares), dans ce cas pas de problème. Sinon, si votre matériel ne gère pas le mixage hardware, vous devez vous assurer qu’aucun autre programme n’utilise la carte son (en passant par OSS).

Pour mieux comprendre comment fonctionne le son sous Linux, vous pouvez consulter cet article.

Une fois tous vos programmes fermés (amarok, rhythmbox, xmms, ...), vérifiez qu’aucun serveur de son n’est lancé. Kde utilise le serveur arts et gnome le serveur esd. Pour vérifier si ces serveurs sont lancés, il vous suffit de taper :
ps ax | grep esd
ps ax | grep arts

puis pour les tuer, tapez :
killall esd
killall arts

ensuite relancer votre jeu.

Si malgré cela, vous n’avez toujours pas de son dans votre jeu, vous devez vérifier que votre noyau est bien compilé avec le support OSS. Pour cela, cherchez dans le fichier de configuration du noyau :
cat /boot/config-`uname -r` | grep OSS
Si cette commande renvoie :
CONFIG_SND_OSSEMUL=y
CONFIG_SOUND_OSS=m

C’est que votre noyau prend en charge le support OSS, il ne vous reste plus qu’à vérifier que les modules sont chargés :
lsmod | grep oss
Si votre noyau ne prend pas en charge le support OSS ou qu’aucun module n’est chargé, vous allez devoir reconfigurer/recompiller votre noyau, mais le sujet est trop vaste pour être abordé sur ce site. Dans ce cas, parcourez les forums dédiés à votre distribution pour trouver plus d’aide.

je l'ai trouvé ici
tout est ok ,sauf ca qui marche pas

Code:

llsmod | grep oss

J'ai Arts installé aussi et pulse audio est désactivé

 

#3 24-06-2008 18:59:24

lululaglue
Administrateur

Re: Pas de son sur America's Army

As-tu essayé de lancer le jeu dans une console pour vois s'il y a avait un message d'erreur ?
As-tu du son dans les autres jeux ? ou dans des appli audio ?


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#4 24-06-2008 19:20:31

Fred6681
Invité

Re: Pas de son sur America's Army

lululaglue a écrit:

As-tu essayé de lancer le jeu dans une console pour vois s'il y a avait un message d'erreur ?
As-tu du son dans les autres jeux ? ou dans des appli audio ?

c'est fait voila le resultat

Code:

[mandriva-user@localhost armyops]$ ./armyops
Cheat protection disabled
open /dev/[sound/]dsp: Device or resource busy
Xlib:  extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Defaulting to false
[mandriva-user@localhost armyops]$

Sinon tout le reste marche bien niveau son, Amarok, Counter strike source, totem, etc...

 

#5 24-06-2008 21:37:27

Valérian
Modérateur

Re: Pas de son sur America's Army

llsmod | grep oss

--> c'est plutôt:

lsmod | grep oss

Hors ligne

 

#6 24-06-2008 21:43:00

Fred6681
Invité

Re: Pas de son sur America's Army

C'est bon, c'est résolu on m'a donné la solution sur un autre forum, merci quand meme
Je met la réponse qu'on m'as donné et qui résout mon problème

Code:

Salut,
j'ai eu le même problème avec Medal of honor qui utilise lui aussi OpenAL.

Ce que j'ai fait pour que ça marche :
Dans le centre de configuration de KDE, Son et Multimédia, Système de sons, onglet général :
décoche "activer le système de son" (je ne sais plus si il faut aussi se reconnecter ensuite)

Je ne sais pas vraiment ce que ça change puisque le son marche comme avant mis à part que du coup il marche aussi avec le jeu.
Voilà j'espère que ça résoudra ton problème.
 

#7 25-06-2008 03:05:02

lululaglue
Administrateur

Re: Pas de son sur America's Army

Hum c'est bizard, l'astuce qu'il te donne est de désactiver le démarrage automatique de arts, le système de multipléxage logiciel de kde.

Normalement le fait de faire un killall arts comme tu le précise dans ton 2ème post, aurait du avoir le même effet (tuer arts, donc libérer le périphérique audio).


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr