Jeuxlinux - Le site des jeux pour linux - Forum

Forum francophone des jeux pour GNU/Linux

Vous n'êtes pas identifié.

#1 17-07-2006 17:00:55

Zhorglub
Invité

[Resolu]Pas de son dans Warsow

Salut,

malgré une bonne recherche je n'arrive pas à avoir de son dans Warsow, et j'obtiens le message

Code:

SDL Audio driver initializing...
Calling SDL_Init(SDL_INIT_AUDIO)...
SDL_Init(SDL_INIT_AUDIO) passed.
SDL audio driver is "(UNKNOWN)"
SDL_OpenAudio() failed: No available audio device
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  135 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0x2e00004
  Serial number of failed request:  70
  Current serial number in output stream:  77

J'utilise ALSA sur une Debian Etch pur jus et dans la doc du jeu, il est spécifié qu'il faut faire export SDL_AUDIODRIVER=alsa et que ça devrait le faire, ben non ça le fait pas :p

d'ailleurs en règle générale, alsa et les jeux c'est pas le top du top. (ça marche parfois avec le wrapper aoss (Wolfenstein:ET du son mais beaucoup de latence et de l'echo) mais pas avec Warsow)

merci pour les tuyaux

A+

 

#2 17-07-2006 17:34:46

JerhuM
Administrateur

Re: [Resolu]Pas de son dans Warsow

je ne suis pas sur mais je croit que warsow utilise oss,
sinon est ce que ton serveur de son es coupé ? ( esd ou arts )

Hors ligne

 

#3 17-07-2006 21:32:20

Zhorglub
Invité

Re: [Resolu]Pas de son dans Warsow

Oui, j'ai killé artsd, mais ça ne change rien.

Je pense que ça vient du support oss dans les options du noyau...

Je vais vérifier...

A+

 

#4 18-07-2006 13:45:11

Zhorglub
Invité

Re: [Resolu]Pas de son dans Warsow

Config noyau:

#
# Advanced Linux Sound Architecture
#
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_RAWMIDI=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_RTCTIMER=m

Nan, elle y est l'emulation oss, là je ne sais plus, ou alors j'ai pas tout compris
(ça par contre, c'est possible big_smile )

A+

 

#5 18-07-2006 16:40:22

lululaglue
Administrateur

Re: [Resolu]Pas de son dans Warsow

Que te renvoie la commande : lsof /dev/dsp ? (juste avant de lancer le jeu)


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

#6 18-07-2006 18:27:30

zhorglub
Membre

Re: [Resolu]Pas de son dans Warsow

Re,

Cool, j'ai réglé le problème...

Son nickel sur warsow et aussi sur Wolfenstein ET

En fait les modules n'étaient pas chargés.. Honte..honte

Code:

modprobe snd-mixer-oss
modprobe snd-pcm-oss
modprobe snd-seq-oss

Je les ai mis dans /etc/modules pour qu'ils se chargent au démarrage.
Il me faut "activer" oss en ouvrant par exemple aumix en ligne de commande
($aumix -d /dev/dsp) sinon ça ne marche pas, mais après c'est nickel!!

Trop content, je vais pouvoir tuer des gens big_smile big_smile big_smile

Ps: ya peut-être moyen de faire plus simple (quoique là, c'est pas trop compliqué) mais ça me va bien comme ça

A+

Hors ligne

 

#7 18-07-2006 18:45:01

lululaglue
Administrateur

Re: [Resolu]Pas de son dans Warsow

Cool, et merci d'avoir donné la réponse wink


http://lululaglue.homelinux.net/userbar/jeuvinux.jpg

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr